Uploaded image for project: 'Snowstorm'
  1. Snowstorm
  2. STORM-2140

LLLineEditor enabled-state cannot properly set via XUI

    Details

    • Type: Defect
    • Status: Closed
    • Priority: Minor
    • Resolution: Released
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Test Plan:
      Hide

      Test according to bug reproduction steps.

      Show
      Test according to bug reproduction steps.

      Description

      Setting the enabled-state of an LLLineEditor via XUI is currently rather broken.

      Repro:
      1. Create an LLLineEditor via XUI and set enabled = false within the XML-file.
      2. Enable the LLLineEditor via code by calling LLLineEditor::setEnabled(TRUE)
      3. Notice the LLLineEditor visually appears to be enabled, but you cannot interact with it in any way

      Alternative repro:
      1. Create an LLLineEditor via XUI and set enabled_control="<SomeBooleanDebugSetting>"
      2. Change debug setting "SomeBooleanDebugSetting"
      3. Notice the LLLineEditor is visually reflecting the change, but the behavior didn't change

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ansariel.hiller Ansariel Hiller
              Contributor:
              Ansariel Hiller
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: