Uploaded image for project: 'Snowstorm'
  1. Snowstorm
  2. STORM-2127

Internal Error: Uncaught Exception is raised whenever these keys are pressed/released: _shift_, _command_, _option_, _control_, or _caps lock_. Can continue but exception is raised continually with these keys. Other keys appear to be fine.



    • Defect
    • Status: Approved
    • Major
    • Resolution: Accepted
    • None
    • None
    • None


      Steps to Reproduce

      Open app. Whenever a "trigger" key is pressed (listed above) within the app an error message is generated. Pressing the key outside the app (focus in Finder or another app) does not generate the error message in SL app.

      Actual Behavior

      Opened the latest (n.b. or any, for that matter) release of Viewer 4, Second Life 4.0.2 (312269) Mar 9 2016 16:52:23 (Second Life Release). If not there already, click within the app window to focus on the app. My last login name is already shown and cursor appears to be focused in the Password field, but that is not necessary. Hit any of the keys listed in the Summary, but not any of the other keys, and a modal windoid pops up with a SL icon and message: "Internal Error / An uncaught exception was raised. Choose "Continue" to continue running in an inconsistent state. Choose "Crash" to halt the application and file a bug with Crash Reporter. Choosing "Crash" will result in the loss of all unsaved data." Available buttons are: "Show Details", "Crash", and "Continue". "Crash" is heavily outlined but "Continue" seems to be the default choice. Choosing "Show Details" opens an embedded scrollable windoid with the report (reproduced below in additional notes). If I keep the offending key held down while clicking "Continue", the exception or crash also happens when the offending key is released (key-up event). Since my password starts with "(" (shift-9), I "crash" immediately. But if I hold down the Shift, click "Continue", type "9", which produces "(", I can do that; however, lifting my finger from the Shift key generates the same error message again. I can press "Continue", eventually finish my password, and log on. The error will repeat, however, any time "Shift" or one of the other trigger keys is pressed.

      Expected Behavior

      Normal typing, for example into name or password field, without error messages.

      Other information

      This error happens in any Version 4 client but does not happen with the last Version 3 client or with the Phoenix Firestorm viewer (Phoenix has just come out with a new Firestorm; I haven't tried it). It did not happen with Version 4.x until recently. This is also happening on another Mac (this one is an iMac 2011, the other is a MacBook Pro 2008). My System and other software is up-to-date. Searching around on the internet brings up the possibility this is a Java error; I have uninstalled Java according to Oracle's instructions (it doesn't feel uninstalled, they just had me disable one item; and perhaps you install your own) but it makes no difference. This error has not appeared in browsers or any other apps. Viewer 4.x.x clients worked fine until about a fortnight ago (ca. March 2) on my iMac. Failure appeared a month earlier on MacBook Pro. Error also happens on older Versions 4.x that previously were fine. No effect of removing TypeIt4Me, removing Java (recently updated), switching keyboards (both Bluetooth and USB). Same problem when data entered via Screen Sharing at a remote MacPro (2005).

      Crash Report:
      Exception Name: NSInternalInconsistencyException
      Descripation: Invalid message sent to event "NSEvent: type=FlagsChanged loc=(0,1413) time=3065.7 flags=0x20102 win=0x7ae53280 winNum=282 ctxt=0x29f6b keyCode=56"
      User Info: (null)

      0 CoreFoundation 0x97153f79 __raiseError + 201
      1 libobjc.A.dylib 0x94c75fd1 objc_exception_throw + 276
      2 CoreFoundation 0x97153dfa +[NSException raise:format:arguments:] + 138
      3 Foundation 0x9100f32b -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 118
      4 AppKit 0x9d14b36d -[NSEvent characters] + 197
      5 Second Life 0x01a9b07f _Z23extractKeyDataFromEventP7NSEventP18NativeKeyEventData + 111
      6 Second Life 0x01a9c4a4 -[LLOpenGLView flagsChanged:] + 36
      7 AppKit 0x9d7870ea -[NSWindow _reallySendEvent:isDelayedEvent:] + 2303
      8 AppKit 0x9d02a927 -[NSWindow sendEvent:] + 567
      9 AppKit 0x9d026942 -[NSApplication sendEvent:] + 2919
      10 AppKit 0x9cf5118f -[NSApplication run] + 1159
      11 AppKit 0x9cecc025 NSApplicationMain + 1630
      12 Second Life 0x000343b5 start + 53




            oz.linden Oz Linden
            cinder.roxley Cinder Roxley
            Cinder Roxley Cinder Roxley
            7 Start watching this issue