Uploaded image for project: 'Snowstorm'
  1. Snowstorm
  2. STORM-2082 Allow saving and loading of graphic settings and ability to control view of "blinged" avatars
  3. STORM-2095

Unable to change Presets when the Preset list contains Preset names using special characters or Preset names that are sorted higher alphabetically then the word Default.

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Unset
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      Affected build: Second Life 3.7.21 (297515) Dec 16 2014 10:11:21 (Second Life Test)

      Steps To Reproduce - Part 1

      • Login on clean settings.
      • Go to Preferences -> Graphics -> Advanced
      • Make an obvious change to graphics settings, for example disable basic shaders
      • Go to "Save as" in the Presets section.
      • Save Preset with the name Übercool (note the Ü has an umlaut)
      • Observe that Übercool is now showing as your selected preset and that basic shaders are disabled.
      • Change back to the Default preset.

      Observed Behaviour

      • After choosing the Default preset in the drop down menu, Übercool preset still shows as the active preset.
      • Graphics settings have changed to the Default preset.
      • Delete the Übercool preset and create a new preset named Ubercool (no umlaut) and observe that you can toggle between the Ubercool and Default preset and everything works as expected.

      Steps To Reproduce - Part 2

      • Delete the Übercool preset.
      • Make a change to graphics settings (disable basic shaders) and save this change with preset name 123
      • Observe that 123 is now showing as your selected preset and that basic shaders are disabled.
      • Change back to the Default preset.

      Observed Behaviour

      • After choosing the Default preset in the drop down menu, 123 preset still shows as the active preset.
      • Graphics settings have changed to the Default preset.

      Steps To Reproduce - Part 3

      • Delete all custom presets.
      • Go to Preferences -> Graphics -> Advanced
      • Make a change to graphics settings (disable basic shaders) and save this change with preset name Dffault (note it is dFfault, not dEfault)
      • Observe that Dffault is now showing as your selected preset and that basic shaders are disabled.
      • Observe that you can toggle between the Dffault and Default preset and everything works as expected.
      • Delete the preset named Dffault
      • Make a change to graphics settings (disable basic shaders) and save this change with preset name Dafault (note it is dAfault, not dEfault)
      • Observe that Dafault is now showing as your selected preset and that basic shaders are disabled.
      • Change back to the Default preset.

      Observed Behaviour

      • Any preset name which is sorted higher alphabetically then the word "Default" will reproduce this bug.
      • After choosing the Default preset in the drop down menu, Dafault preset still shows as the active preset.
      • Graphics settings have changed to the Default preset.
      • Preset names containing * or @ or ! etc all reproduce

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            whirly.fizzle Whirly Fizzle
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                PagerDuty