Uploaded image for project: 'Snowstorm'
  1. Snowstorm
  2. STORM-1862

The left-hand border of the input field for IMs is missing

    Details

    • Type: Defect
    • Status: Closed
    • Priority: Minor
    • Resolution: Released
    • Affects Version/s: None
    • Fix Version/s: Active
    • Labels:
    • Environment:
    • Acceptance Criteria:
      The input field has a lovely teal border again,and everything else works fine still

      Description

      See attached pic - the left-hand teal border is missing - this is causes by a bug in the floater_im_session.xml file. I have corrected this and an incorrect sizing (the layout_panel is 10 too wide) below with code changes for floater_im_session.xml:

      Current Viewer code:
      <layout_panel
      default_tab_group="3"
      left="0"
      tab_group="2"
      top="0"
      height="200"
      width="254"
      user_resize="true">
      <button
      height="20"
      follows="left|top"
      top="0"
      left="2"
      image_overlay="TabIcon_Open_Off"
      layout="topleft"
      width="25"
      name="slide_left_btn" />
      <button
      height="20"
      follows="left|top"
      top="0"
      left="2"
      image_overlay="TabIcon_Close_Off"
      width="25"
      name="slide_right_btn" />
      <chat_history
      font="SansSerifSmall"
      follows="left|right|top|bottom"
      height="150"
      name="chat_history"
      parse_highlights="true"
      parse_urls="true"
      left="1"
      width="249">
      </chat_history>
      <line_editor
      bottom="0"
      follows="left|right|bottom"
      font="SansSerifSmall"
      height="20"
      label="To"
      layout="bottomleft"
      name="chat_editor"
      tab_group="3"
      width="249">
      </line_editor>
      </layout_panel>

      New code should be:
      <layout_panel
      default_tab_group="3"
      left="0"
      tab_group="2"
      top="0"
      height="200"
      width="244"
      user_resize="true">
      <button
      height="20"
      follows="left|top"
      top="0"
      left="2"
      image_overlay="TabIcon_Open_Off"
      layout="topleft"
      width="25"
      name="slide_left_btn" />
      <button
      height="20"
      follows="left|top"
      top="0"
      left="2"
      image_overlay="TabIcon_Close_Off"
      width="25"
      name="slide_right_btn" />
      <chat_history
      font="SansSerifSmall"
      follows="left|right|top|bottom"
      height="150"
      name="chat_history"
      parse_highlights="true"
      parse_urls="true"
      left="1"
      width="238">
      </chat_history>
      <line_editor
      bottom="0"
      left="3"
      follows="left|right|bottom"
      font="SansSerifSmall"
      height="20"
      label="To"
      layout="bottomleft"
      name="chat_editor"
      tab_group="3"
      width="236">
      </line_editor>

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                hitomi.tiponi Hitomi Tiponi
                Extended Group Visibility:
                jira-users
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: