Uploaded image for project: 'Snowstorm'
  1. Snowstorm
  2. STORM-1812 Music stream does not always restart after teleporting
  3. STORM-1861

Media auto-play is off - but music stream starts to play anyway when teleport fails

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Released
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Environment:

      Description

      I tried to TP to a region that was pretty overcrowded or even offline tonight (http://maps.secondlife.com/secondlife/FATEisland/128/128/24), so 9 out of 10 attempts failed. That's normal, I know .

      What's not normal at all: after the "Teleport failed" screen appeared, sometimes the music stream started to play automatically - although "auto-play" is switched OFF in "Preferences..."!!! I reproduced this from different starting locations.

      Steps to reproduce:

      1. Go to Preferences... > Sound & Media and turn "Allow Media to auto-play" OFF.
      1. Go to a location with audio stream. Check if it's playing and turn it off again.
      2. Look for a region that's offline or where there's no access due to "agent limit".
      3. Try to teleport there.
      4. TP should fail.
      5. After a few seconds, the audio stream may start. If not, retry step 3.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jonathan.yap Jonathan Yap
                Extended Group Visibility:
                jira-users
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: