Uploaded image for project: 'Snowstorm'
  1. Snowstorm
  2. STORM-117

Some particles don't disappear when UI is hidden

    Details

    • Type: Story
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Sprint 3, Viewer 2.2.0
    • Labels:
      None
    • Environment:

      Description

      Fixing this would be useful for machinima-makers, who film Second Life with the user interface off (Ctrl-Alt-F1 or Client menu > Rendering > Features > UI). I've heard a few complaints about it:

      • Go to a crowded area where avatars are teleporting in and out frequently. Wait a few minutes.
      • Observe: Colored particle rings stay.
        = Expected: Colored particle rings should disappear shortly, just like when the UI is on.

      This also affects your avatar's selection beam (which can be hidden via Tools menu).

      A partial workaround is to hide particles, but that's less-than-desirable if your cinematic scene includes particle-emitting objects.

        Attachments

        1. better.patchfile
          4 kB
          Mm Alder
        2. particles keep swirling around.jpg
          239 kB
          Torley Linden

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                torley.linden Torley Linden
                Prod Owner Approved:
                Merov Linden
                Extended Group Visibility:
                jira-users
              • Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: