Uploaded image for project: 'Open Development'
  1. Open Development
  2. OPEN-274

your /indra/newview/viewer_manifest.py

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Unset
    • Resolution: Unresolved
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux debian 7 and up kubuntu 12.04 kubuntu 14.04 slackware 14.0 14.1

      Description

      Steps to Reproduce

      using the viewer

      Actual Behavior

      incompatible libraries the webkit will not seek shared lib

      Expected Behavior

      webkit us system qt

      Other information

      here is the fix all you need is the llqtwebkit and the liQtWebkit it is built against. your forcing the viewer to use libQtCore.so, libQtGui.so, libQtNetwork.so, libQtOpenGL.so, libQtSvg.so, libQtXml.so.
      if you pull these libraries from your /viewer/lib it will still use the codecs llqtwbkit was built against.
      but it will call on the systems shared libraries to handle linux specific systems.
      it would be nice if we all used debian the same as what Monty is building on. but. we don't.
      this fix works on debian 7 slackware 14.0 and up kubuntu 12.04 and 14.04
      as noted your making the system use incompatible libraries. And this is breaking the shared links that the users linux operating system uses.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            drakeo Drakeo
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                PagerDuty