Uploaded image for project: 'Open Development'
  1. Open Development
  2. OPEN-186

Linux Platform; Automatic update results in no working SL viewer.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Finish
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux

      Description

      ====Scenario====
      User; First name : ImHappy Last name : LeaveMeAlone

      ImHappy LeaveMeAlone is using Debian Squeeze or a derivative thereof whose SL viewer work fine and dandy; is forced to update. After which the new Second Life viewer will not start.

      Now the situation is the old viewer demands to update and the new viewer will not start.

      Investigation reveals,
      @squeeze32:~$ uname -a
      Linux squeeze32 2.6.32-5-686 #1 SMP Fri May 10 08:33:48 UTC 2013 i686 GNU/Linux

      (gdb) run
      Starting program: /home/bill/Desktop/SecondLife-i686-3.6.3.279564/bin/do-not-directly-run-secondlife-bin
      /home/bill/Desktop/SecondLife-i686-3.6.3.279564/bin/do-not-directly-run-secondlife-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/bill/Desktop/SecondLife-i686-3.6.3.279564/bin/do-not-directly-run-secondlife-bin)

      Program exited with code 01.

      It appears that the cause is a build of the viewer on a multi-arch distribution breaks the viewer when it is run on a non multi-arch distribution.

      Viewers (confirmed on Kokua) built on Squeeze (non-multi-arch gcc-4.4.5) do not have the problem.

        Attachments

          Activity

            People

            • Assignee:
              oz.linden Oz Linden
              Reporter:
              nicky.perian Nicky Perian
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: