Uploaded image for project: 'Open Development'
  1. Open Development
  2. OPEN-10

cannot run autobuild's setup.py without specifying interpreter command (not executable and lacking shebang)

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: In QA
    • Priority: Trivial
    • Resolution: Fixed
    • Component/s: autobuild
    • Labels:
    • Environment:
      Funtoo Linux (a Gentoo Linux variant)
      Python 2.6.6

      (probably affects all UNIX-like systems)
    • Approvals:
      Code Review
    • Acceptance Criteria:
      Step 3 of the repro should have the same effect as the workaround, i.e. install autobuild system-wide.

      Description

      To reproduce

      1. hg clone https://bitbucket.org/lindenlab/autobuild

      2. cd autobuild

      3. sudo setup.py install

      Expected

      Autobuild will be installed system-wide

      Observed

      sudo: setup.py: command not found

      Workaround

      Instead of step 3 above, do

      sudo python setup.py install

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              boroondas.gupte Boroondas Gupte
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 2 hours
                2h
                Remaining:
                Time Spent - 1 hour, 30 minutes Remaining Estimate - 30 minutes
                30m
                Logged:
                Time Spent - 1 hour, 30 minutes Remaining Estimate - 30 minutes
                1h 30m